domains got create at mysql level but not on system level

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

domains got create at mysql level but not on system level

Kebba Foon
HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is running.
when i create users on the exim4u web interface, the users got created on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba





Reply | Threaded
Open this post in threaded view
|

Re: domains got create at mysql level but not on system level

gldickens3
Administrator
Hello,

This is most likely an operating system permissions issue.  Please check
the permissions of your mail store's parent directory.

If you haven't done so, you may need to create a mail store folder in
the directory where you are storing your mail.  For example, if you are
storing your mail in the directory:

    /home/exim4u/mail

Then, you need to create the mail folder as follows:

    mkdir /home/exim4u/mail

Also, make sure that your mail store directory is writable by the
uid/gid that you specified when you created the domain in Exim4U's email
admin.

Good luck and thanks for using Exim4U.

Gordon Dickens



[hidden email] wrote:

> HI
>
> i am testing the exim4u email server, i have followed the installation
> instruction on the website and did everything. the exim daemon is running.
> when i create users on the exim4u web interface, the users got created on
> the mysql database but there is no domain folder created on system for
> exim. i created a user for the system gid and uid. i dont know what am
> doing wrong please help, i cannot find out anything in the logs.
>
> Kebba
>
>
>
>
> _______________________________________________
> users mailing list
> [hidden email]
> https://exim4u.org/mailman/listinfo/users
>  



Reply | Threaded
Open this post in threaded view
|

Re: domains got create at mysql level but not on system level

Kebba Foon
In reply to this post by Kebba Foon
i have check the permissions and everything is find if i login with the
users the mail boxes belong to i can create directories, i have check and
cross check my permission i even created a tmp folder with 777 permission.
i dont see any permission error if i check my apache logs. am using debian

> Send users mailing list submissions to
> [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://exim4u.org/mailman/listinfo/users
> or, via email, send a message with subject or body 'help' to
> [hidden email]
>
> You can reach the person managing the list at
> [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of users digest..."
>
>
> Today's Topics:
>
>    1. domains got create at mysql level but not on system level
>       ([hidden email])
>    2. Re: domains got create at mysql level but not on system level
>       (Gordon Dickens)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Fri, 22 Jan 2010 13:12:57 -0000 (GMT)
> From: [hidden email]
> Subject: [Exim4U] domains got create at mysql level but not on system
> level
> To: [hidden email]
> Message-ID: <[hidden email]>
> Content-Type: text/plain;charset=iso-8859-1
>
> HI
>
> i am testing the exim4u email server, i have followed the installation
> instruction on the website and did everything. the exim daemon is running.
> when i create users on the exim4u web interface, the users got created on
> the mysql database but there is no domain folder created on system for
> exim. i created a user for the system gid and uid. i dont know what am
> doing wrong please help, i cannot find out anything in the logs.
>
> Kebba
>
>
>
>
>
>
> ------------------------------
>
> Message: 2
> Date: Fri, 22 Jan 2010 08:18:29 -0500
> From: Gordon Dickens <[hidden email]>
> Subject: Re: [Exim4U] domains got create at mysql level but not on
> system level
> To: Exim4U General Discussion <[hidden email]>
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> Hello,
>
> This is most likely an operating system permissions issue.  Please check
> the permissions of your mail store's parent directory.
>
> If you haven't done so, you may need to create a mail store folder in
> the directory where you are storing your mail.  For example, if you are
> storing your mail in the directory:
>
>     /home/exim4u/mail
>
> Then, you need to create the mail folder as follows:
>
>     mkdir /home/exim4u/mail
>
> Also, make sure that your mail store directory is writable by the
> uid/gid that you specified when you created the domain in Exim4U's email
> admin.
>
> Good luck and thanks for using Exim4U.
>
> Gordon Dickens
>
>
>
> [hidden email] wrote:
>> HI
>>
>> i am testing the exim4u email server, i have followed the installation
>> instruction on the website and did everything. the exim daemon is
>> running.
>> when i create users on the exim4u web interface, the users got created
>> on
>> the mysql database but there is no domain folder created on system for
>> exim. i created a user for the system gid and uid. i dont know what am
>> doing wrong please help, i cannot find out anything in the logs.
>>
>> Kebba
>>
>>
>>
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://exim4u.org/mailman/listinfo/users
>>
>
>
>
>
> ------------------------------
>
> _______________________________________________
> users mailing list
> [hidden email]
> https://exim4u.org/mailman/listinfo/users
>
>
> End of users Digest, Vol 2, Issue 2
> ***********************************
>




Reply | Threaded
Open this post in threaded view
|

Re: domains got create at mysql level but not on system level

gldickens3
Administrator
Hi Kebba,

Here are some things to check.  This should at least tell us if this is a permissions problem or not.

When you created the domain, your mail store directory was saved in the mysql field "maildir" in the domains table and in the mysql fields "smtp" and "pop" in the user table.  Verify that the values of those fields reflect what you entered in the exim4u web interface.

Also, when a domain is created, Exim4U sends a welcome email to the domain administrator and this is what creates the mail store directory.  That is, the exim MTA should initially create the mail store directory with this welcome email.  Therefore, check your exim logs and, if exim was unable to create the mail store directory, you should see an error in the logs showing exim trying to save the welcome mail to the mail store directory.  The error should be something like: "Permission denied: cannot create <mail store directory>".

Assuming that the mysql database "maildir", "smtp" and "pop" values are correct for your domain and that the exim logs show permission errors where exim has attempted to save the welcome mail into the correct directory then the problem must be a permissions problem.  Otherwise, if the values are incorrect and/or if there aren't any entries in your exim logs then the problem could be something else.

Gordon




[hidden email] wrote:
i have check the permissions and everything is find if i login with the
users the mail boxes belong to i can create directories, i have check and
cross check my permission i even created a tmp folder with 777 permission.
i dont see any permission error if i check my apache logs. am using debian

  
Send users mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	https://exim4u.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."


Today's Topics:

   1. domains got create at mysql level but not on system level
      ([hidden email])
   2. Re: domains got create at mysql level but not on system level
      (Gordon Dickens)


----------------------------------------------------------------------

Message: 1
Date: Fri, 22 Jan 2010 13:12:57 -0000 (GMT)
From: [hidden email]
Subject: [Exim4U] domains got create at mysql level but not on system
	level
To: [hidden email]
Message-ID: [hidden email]
Content-Type: text/plain;charset=iso-8859-1

HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is running.
when i create users on the exim4u web interface, the users got created on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba






------------------------------

Message: 2
Date: Fri, 22 Jan 2010 08:18:29 -0500
From: Gordon Dickens [hidden email]
Subject: Re: [Exim4U] domains got create at mysql level but not on
	system level
To: Exim4U General Discussion [hidden email]
Message-ID: [hidden email]
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hello,

This is most likely an operating system permissions issue.  Please check
the permissions of your mail store's parent directory.

If you haven't done so, you may need to create a mail store folder in
the directory where you are storing your mail.  For example, if you are
storing your mail in the directory:

    /home/exim4u/mail

Then, you need to create the mail folder as follows:

    mkdir /home/exim4u/mail

Also, make sure that your mail store directory is writable by the
uid/gid that you specified when you created the domain in Exim4U's email
admin.

Good luck and thanks for using Exim4U.

Gordon Dickens



[hidden email] wrote:
    
HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is
running.
when i create users on the exim4u web interface, the users got created
on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba




_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users

      

------------------------------

_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users


End of users Digest, Vol 2, Issue 2
***********************************

    



_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users