Re: users Digest, Vol 2, Issue 3

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: users Digest, Vol 2, Issue 3

Kebba Foon
Hi Gordon,

Checking my exim mail queue i saw pending mails to the new domains i created:
2010-01-22 12:22:28 Received from [hidden email] U=www-data P=local
S=601 T="Welcome Domain Admin!"
2010-01-22 12:22:28 [hidden email] R=ditch_spam_for_relay_MX_direct
defer (-1): condition check lookup defer

i dont know if this mean anything, but the welcome mail seems to be seen
when the domain is initially created on the mysql.

Kebba


> Send users mailing list submissions to
> [hidden email]
>
> To subscribe or unsubscribe via the World Wide Web, visit
> https://exim4u.org/mailman/listinfo/users
> or, via email, send a message with subject or body 'help' to
> [hidden email]
>
> You can reach the person managing the list at
> [hidden email]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of users digest..."
>
>
> Today's Topics:
>
>    1. Re: domains got create at mysql level but not on system level
>       ([hidden email])
>    2. Re: domains got create at mysql level but not on system level
>       (Gordon Dickens)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Fri, 22 Jan 2010 18:05:43 -0000 (GMT)
> From: [hidden email]
> Subject: Re: [Exim4U] domains got create at mysql level but not on
> system level
> To: [hidden email]
> Message-ID: <[hidden email]>
> Content-Type: text/plain;charset=iso-8859-1
>
> i have check the permissions and everything is find if i login with the
> users the mail boxes belong to i can create directories, i have check and
> cross check my permission i even created a tmp folder with 777 permission.
> i dont see any permission error if i check my apache logs. am using debian
>
>> Send users mailing list submissions to
>> [hidden email]
>>
>> To subscribe or unsubscribe via the World Wide Web, visit
>> https://exim4u.org/mailman/listinfo/users
>> or, via email, send a message with subject or body 'help' to
>> [hidden email]
>>
>> You can reach the person managing the list at
>> [hidden email]
>>
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of users digest..."
>>
>>
>> Today's Topics:
>>
>>    1. domains got create at mysql level but not on system level
>>       ([hidden email])
>>    2. Re: domains got create at mysql level but not on system level
>>       (Gordon Dickens)
>>
>>
>> ----------------------------------------------------------------------
>>
>> Message: 1
>> Date: Fri, 22 Jan 2010 13:12:57 -0000 (GMT)
>> From: [hidden email]
>> Subject: [Exim4U] domains got create at mysql level but not on system
>> level
>> To: [hidden email]
>> Message-ID: <[hidden email]>
>> Content-Type: text/plain;charset=iso-8859-1
>>
>> HI
>>
>> i am testing the exim4u email server, i have followed the installation
>> instruction on the website and did everything. the exim daemon is
>> running.
>> when i create users on the exim4u web interface, the users got created
>> on
>> the mysql database but there is no domain folder created on system for
>> exim. i created a user for the system gid and uid. i dont know what am
>> doing wrong please help, i cannot find out anything in the logs.
>>
>> Kebba
>>
>>
>>
>>
>>
>>
>> ------------------------------
>>
>> Message: 2
>> Date: Fri, 22 Jan 2010 08:18:29 -0500
>> From: Gordon Dickens <[hidden email]>
>> Subject: Re: [Exim4U] domains got create at mysql level but not on
>> system level
>> To: Exim4U General Discussion <[hidden email]>
>> Message-ID: <[hidden email]>
>> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>>
>> Hello,
>>
>> This is most likely an operating system permissions issue.  Please check
>> the permissions of your mail store's parent directory.
>>
>> If you haven't done so, you may need to create a mail store folder in
>> the directory where you are storing your mail.  For example, if you are
>> storing your mail in the directory:
>>
>>     /home/exim4u/mail
>>
>> Then, you need to create the mail folder as follows:
>>
>>     mkdir /home/exim4u/mail
>>
>> Also, make sure that your mail store directory is writable by the
>> uid/gid that you specified when you created the domain in Exim4U's email
>> admin.
>>
>> Good luck and thanks for using Exim4U.
>>
>> Gordon Dickens
>>
>>
>>
>> [hidden email] wrote:
>>> HI
>>>
>>> i am testing the exim4u email server, i have followed the installation
>>> instruction on the website and did everything. the exim daemon is
>>> running.
>>> when i create users on the exim4u web interface, the users got created
>>> on
>>> the mysql database but there is no domain folder created on system for
>>> exim. i created a user for the system gid and uid. i dont know what am
>>> doing wrong please help, i cannot find out anything in the logs.
>>>
>>> Kebba
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> https://exim4u.org/mailman/listinfo/users
>>>
>>
>>
>>
>>
>> ------------------------------
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> https://exim4u.org/mailman/listinfo/users
>>
>>
>> End of users Digest, Vol 2, Issue 2
>> ***********************************
>>
>
>
>
>
>
> ------------------------------
>
> Message: 2
> Date: Fri, 22 Jan 2010 17:37:07 -0500
> From: Gordon Dickens <[hidden email]>
> Subject: Re: [Exim4U] domains got create at mysql level but not on
> system level
> To: Exim4U General Discussion <[hidden email]>
> Message-ID: <[hidden email]>
> Content-Type: text/plain; charset="us-ascii"
>
> An HTML attachment was scrubbed...
> URL:
> http://exim4u.org/pipermail/users/attachments/20100122/def115e8/attachment-0001.html
>
> ------------------------------
>
> _______________________________________________
> users mailing list
> [hidden email]
> https://exim4u.org/mailman/listinfo/users
>
>
> End of users Digest, Vol 2, Issue 3
> ***********************************
>




Reply | Threaded
Open this post in threaded view
|

Re: users Digest, Vol 2, Issue 3

gldickens3
Administrator
Hi Kebba,

Ok, your exim logs have told me what the problem likely is.  That is, the "condition check lookup defer" log message in the ditch_spam_for_relay_MX_direct router indicates that exim may not be successfully reading the mysql database.  While I am not 100% certain that this is your problem, this has been the problem every time I have previously seen that in the logs.  Exim shouldn't even be executing that router for your welcome message and the only way that I can figure why is if exim is not reading the mysql database.

You therefore need to verify all of your configuration settings for exim's access to the mysql database.  Check this line in /etc/exim4u_local.conf.inc:

hide mysql_servers = localhost::(/var/lib/mysql/mysql.sock)/exim4u/exim4u/CHANGE

For your Debian installation, this line should read:

hide mysql_servers = localhost::(/var/run/mysqld/mysqld.sock)/exim4u/Debian-exim/CHANGE

That is, the default socket file name is /var/run/mysqld/mysqld.sock in Debian/Ubuntu whereas the default socket file name of /var/lib/mysql/mysql.sock is correct for Red Hat and CentOS. Also, replace CHANGE with your password.  This also assumes that you are running exim under the Debian-exim username.  If that is not the case then replace Debian-exim with the username that you are running exim under.

FYI,

Gordon



[hidden email] wrote:
Hi Gordon,

Checking my exim mail queue i saw pending mails to the new domains i created:
2010-01-22 12:22:28 Received from [hidden email] U=www-data P=local
S=601 T="Welcome Domain Admin!"
2010-01-22 12:22:28 [hidden email] R=ditch_spam_for_relay_MX_direct
defer (-1): condition check lookup defer

i dont know if this mean anything, but the welcome mail seems to be seen
when the domain is initially created on the mysql.

Kebba


  
Send users mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	https://exim4u.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."


Today's Topics:

   1. Re: domains got create at mysql level but not on system	level
      ([hidden email])
   2. Re: domains got create at mysql level but not on system level
      (Gordon Dickens)


----------------------------------------------------------------------

Message: 1
Date: Fri, 22 Jan 2010 18:05:43 -0000 (GMT)
From: [hidden email]
Subject: Re: [Exim4U] domains got create at mysql level but not on
	system	level
To: [hidden email]
Message-ID: [hidden email]
Content-Type: text/plain;charset=iso-8859-1

i have check the permissions and everything is find if i login with the
users the mail boxes belong to i can create directories, i have check and
cross check my permission i even created a tmp folder with 777 permission.
i dont see any permission error if i check my apache logs. am using debian

    
Send users mailing list submissions to
	[hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
	https://exim4u.org/mailman/listinfo/users
or, via email, send a message with subject or body 'help' to
	[hidden email]

You can reach the person managing the list at
	[hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of users digest..."


Today's Topics:

   1. domains got create at mysql level but not on system level
      ([hidden email])
   2. Re: domains got create at mysql level but not on system level
      (Gordon Dickens)


----------------------------------------------------------------------

Message: 1
Date: Fri, 22 Jan 2010 13:12:57 -0000 (GMT)
From: [hidden email]
Subject: [Exim4U] domains got create at mysql level but not on system
	level
To: [hidden email]
Message-ID: [hidden email]
Content-Type: text/plain;charset=iso-8859-1

HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is
running.
when i create users on the exim4u web interface, the users got created
on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba






------------------------------

Message: 2
Date: Fri, 22 Jan 2010 08:18:29 -0500
From: Gordon Dickens [hidden email]
Subject: Re: [Exim4U] domains got create at mysql level but not on
	system level
To: Exim4U General Discussion [hidden email]
Message-ID: [hidden email]
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

Hello,

This is most likely an operating system permissions issue.  Please check
the permissions of your mail store's parent directory.

If you haven't done so, you may need to create a mail store folder in
the directory where you are storing your mail.  For example, if you are
storing your mail in the directory:

    /home/exim4u/mail

Then, you need to create the mail folder as follows:

    mkdir /home/exim4u/mail

Also, make sure that your mail store directory is writable by the
uid/gid that you specified when you created the domain in Exim4U's email
admin.

Good luck and thanks for using Exim4U.

Gordon Dickens



[hidden email] wrote:
      
HI

i am testing the exim4u email server, i have followed the installation
instruction on the website and did everything. the exim daemon is
running.
when i create users on the exim4u web interface, the users got created
on
the mysql database but there is no domain folder created on system for
exim. i created a user for the system gid and uid. i dont know what am
doing wrong please help, i cannot find out anything in the logs.

Kebba




_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users

        

------------------------------

_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users


End of users Digest, Vol 2, Issue 2
***********************************

      


------------------------------

Message: 2
Date: Fri, 22 Jan 2010 17:37:07 -0500
From: Gordon Dickens [hidden email]
Subject: Re: [Exim4U] domains got create at mysql level but not on
	system level
To: Exim4U General Discussion [hidden email]
Message-ID: [hidden email]
Content-Type: text/plain; charset="us-ascii"

An HTML attachment was scrubbed...
URL:
http://exim4u.org/pipermail/users/attachments/20100122/def115e8/attachment-0001.html

------------------------------

_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users


End of users Digest, Vol 2, Issue 3
***********************************

    



_______________________________________________
users mailing list
[hidden email]
https://exim4u.org/mailman/listinfo/users